Using the 824 Utility Software

824 Utility Software Overview
The 824 Utility software is a powerful tool for use with the
System 824 from Larson Davis. This software will allow
you to control, setup, download and translate your 824 and
measurement data quickly and easily.
The 824 Utility program has three sections that perform the
functions on the 824.

NOTE: 824 Utility software requires 824
firmware version 1.011 or greater. For
the newer instrument ID’s, (TAL FFT,
and RTA) 2.100 or greater is required.

•

The setup section provides support for creating, editing,
storing and retrieving setups from the 824 and from files

•

The download section provides a means by which to
retrieve the measurement data from the 824.

•

The translate section provides support for translating the
downloaded measurement data, and displaying or printing it in a text format, or exporting the measurement data
to a spread sheet program.

In this chapter will discuss installing the software, getting
the software started on your computer, connecting the 824 to
the serial port of your computer, the Main Screen Toolbar
functions, and then go onto discuss each of the three functions of the software in greater depth.

824 Utility Installation
To install the 824 Utility software package place the disk
labeled “disk 1” into the floppy drive. From Windows 95

12/10/99

Using the 824 Utility Soware

9-1

press START and then select the RUN menu item. A prompt
will appear to enter the program name. Enter
“A:\SETUP.EXE”.
The 824 utility software will automatically begin the installation process. The installer program will prompt you
through the installation. A prompt will appear asking to
place disk 2 into the floppy drive. Place disk 2 into the
floppy drive. A message will appear indicating that the software was successfully installed.

Starting the 824 Utility Software
To start the 824 Utility software in Windows 95, press
START and then select the Programs/Larson-Davis/824Util
submenu item.

Connecting the 824 to Your Computer
To connect the 824 to a computer, use the CBL006 cable
included with you System 824. The round 8-pin connector
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plugs into the Serial port of the 824 and the 9-pin connector
plugs into a serial port on your computer.

Before any functions can be performed on the 824, you must
connect the 824 to the 824 Utility software. To connect to
the 824.

NOTE: The 824 will power on when it
senses anything on the serial connector.
You may notice the 824 powering on
automatically before you press the power
button.
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Step 1

Attach the CBL006 to the 824 and to the serial
port on the computer as described earlier.

Step 2

Start the 824 Utility program.

Step 3

Power on the 824.

Step 4

Press the Connect button on the tool bar.

Step 5

The connect dialog box will appear.
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NOTE: Please see Chapter 3 of this
manual for details on changing the communications parameters on the 824.

Step 6 Make sure that the settings on the dialog box
match the settings on the 824, and press the connect button.
After a successful connection, the setup window will appear
with a system setup in the setup list box. The 824’s serial
number and title should be reported on the setup dialog box
screen.

824 Utility Tool Bar
The tool bar for the 824 Utility program provides support for
the main functions of the 824 Utility program. All Toolbar
functions can also be performed from the pull down menus
at the top of the 824 Utility Software screen.
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Connect button. This button is used to establish a connection to the 824. Pressing this button will bring up the connect dialog box, where
the connection parameters can be defined.

Retrieve Setups from 824. This button will
retrieve all current setups in the 824.

Create new setup button. This button will
allow the used to create a new setup that can
then be saved to disk, or saved in the 824.

Open a setup from a computer file. This button
will allow you to retrieve previously stored
setup file.

Store setup to disk. This button will allow the
user to store a setup to a disk.

Store setup in 824. This button will store the
setup in the 824. This function must be performed before the setup can be used inside the
824.
Setup window button. This button will activate
the setup window portion of the 824 Utility
Program
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Download window button. This button will
open the download section of the 824 Utility
program.

Translate window button. This button will
open the translate section of the program. It
will provide a file tree where the contents of
the downloaded measurement files can be
viewed.
Export measurement button. Exports the currently selected measurement file to a user
defined spreadsheet program. This button will
only be active when you are in the translate
section of the program, and there is a measurement text file being displayed.

824 Utility Setup Window
The setup window is the default window that will open up
when the 824 Utility program is started. The setup window
will allow you to edit existing setups, retrieve setups from
the 824 or a file, create new setups, and store setups to the
824 or to a file.
The main setup window has 2 sections: the setup list box,
and the settings dialog section. The setup list box will list all
setups that have either been created or retrieved from the
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824 or a disk file. The settings dialog section will allow you
to manipulate the setup.

Setup List Box

Settings Tab Dialog

Retrieving setups from the 824
Setups stored in the 824 can be retrieved by clicking on the
Get Setup button on the tool bar or by selecting Get Setups
From 824 from the File Menu.
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Setups will be retrieved from the 824 and will be displayed
in the Setup listbox.

In the list of setup files, the system setup is the first setup
and is followed by all of the permanent and user-defined setups. In the setup list box, there are several parts of the Setup
title that can be used to identify the setup type.
The title of the ID is listed in the right hand column. For
the permanent ID’s, this will be the Larson Davis
instrument type. For a user defined ID, this can be anything that the user defines.
The three letter Larson Davis assigned
name is listed in the blue Ovals. This
indicates the type of instrument ID the
setup was created in.
‘P’ stands for a permanent ID. This would be
an original setup defined at Larson Davis.

A lock icon in this place, indicates a
user ID that has been locked so it cannot be modified.

No letter, or an arrow, indicate a User defined ID.

Highlighting one of the setups in the list displays all of the
available settings in the setup dialog box (right side of the
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window). The setups are organized and grouped similar to
the 824 menu structure in the instrument. Click on the different tabs to access all of the setup parameters.

Select different tabs to access
all of the setup functions.

Parameters can be entered manually,
or the pull down selections can be
used.

Modifying and Storing Setups to the 824
NOTE: If you change settings in the Utility program to an active setup in the 824,
those changes will not take affect in the
824, until another setup is selected, and
the modified setup is re-loaded.

With the 824 Utility software you can make modifications to
any of the setups. For example, in the System setup, you can
change any of the parameters for the Title, Calibration,
Power, Date/Time or Controls and then send the modified
setup to the 824. To store the modified setup, select the Save
Setup to 824 menu item from the File menu or click on the
Store Setup in 824 button on the tool bar.

Changing System Settings

The system selection on the setup list box contains the general settings for the 824. The selections here include, Title,
Options, Calibration, Power, Date and Time, and Controls.
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To change one of these settings, click on the appropriate tab,
and enter the changes.

Manipulating a Setup
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To change any of the variables for a particular setup, select
the setup. The appropriate setup tab dialog will appear at the
right of the setup list box. Select the setting you wish to
change and enter the new value.
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You can also access several setup functions by right clicking
on the Setup in the Setup list box.
The following functions can be accessed by pressing the
right mouse button while within the Setup list box. The
Setup Menu items will appear enabled or disabled depending on the setup selected. For example, it is not possible to
delete a permanent 824 setup, so the Delete Setup menu
item will be disabled if a permanent 824 setup is selected.

The Rename Setup button allows you to
rename the current setup.

The Make Setup Current button will cause the
currently selected setup become the Active
setup in the 824.

The Lock Setup button will lock the current
setup. The Lock icon will not appear until the
setup is retrieved again from the 824.

The Unlock Setup button will unlock the currently selected setup.

The Delete setup button will delete the currently selected setup.
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Saving Setups to Disk Files
Once you have created or modified a setup, you can store the
setup to a file. Select the Save Setup to a File menu item
from the File menu or click on the Save to File button on the
tool bar.

NOTE: The system setup is automatically updated each time the 824 Utility is
connected to the 824.

The 824 Utility program will bring up a standard windows
save dialog box, where the file name and location of the
setup can be specified.

The System setup can be modified and stored back into the
824, but cannot be saved to a disk file.

Opening Setup Disk Files
To open a setup disk file select the Open Setup File menu
item from the File menu or click on the Open File button on
the tool bar.
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A standard windows Open File box will appear. Select the
file folder that contains the file and select the setup file you
want.

The setup appears in the Select Setup list box. You can then
select (highlight) the desired setup in the list. The highlighted setup can then be sent to the 824 by selecting the
Save Setup to 824 menu item from the File menu.

Other menu items available in the Setup Menu include
renaming, locking, unlocking, deleting, or making the
selected setup the active setup.
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Creating a New Setup
You create new setups by selecting the New Setup menu
item from the File menu or by selecting the New Setup button on the tool bar.

A dialog box will be displayed to allow the type of the new
setup to be selected.

Press the OK button and you will now see the new setup in
the Setup List box.
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The new setup is now defined for a particular instrument ID,
and can be modified from the Setup List box. After creating
a new setup, you can store it to a disk file, or send it to the
824.

Renaming an Existing Setup
To rename an existing setup, right click on the setup in the
left hand side of the screen and select Rename Setup from
the popup menu.

A dialog box will be displayed to allow you to change the
name of the selected setup.

Enter the new name for the setup, and press the OK button.
NOTE: The permanent setup ID’s in the
824 cannot be renamed.

After renaming a setup, you can store it to a disk file, or send
it to the 824.

Deleting an Existing Setup
To delete an existing setup, right click on the setup in the left
hand side of the screen and select Delete Setup from the
popup menu.
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NOTE: This section applies only to setups that exist on the 824. If a new setup
or a setup that is stored to disk is deleted,
this message will not appear.

WARNING!

Pressing the Delete Setup button will bring up a prompt asking if you are sure you want to delete the setup.

The setup will be deleted from the 824 and the Utility program.

Locking and Unlocking Setups
To prevent accidently deleting a setup, right click on the
desired setup and select Lock Setup from the popup menu.
Note that if you have just created a new setup, the setup
must first be stored to the 824 before it can be locked.
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Downloading Measurement Data
The download section of the 824 Utility Software is the next
section we will discuss.
To display measurement data stored in the 824, select Download View from the View menu or hit the Download View
button from the tool bar.

All stored measurement information is retrieved from the
824 and displayed in the Download View window.

The first entry in the Measurement list box displays information about the active measurement currently in the 824.
Following the active measurement is a list of all other Data
Files stored in the 824.
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The measurements are again identified the same way the setups were identified in the Setup List Box in the setup portion
of the 824 Utility manual.
The title of the ID is listed in the right hand column.
For the permanent ID’s, this will be the Larson
Davis instrument type. For a user defined ID, this
can be anything that the user defines.

The three letter Larson Davis assigned name is
listed in the blue Ovals. This indicates the type of
instrument ID the setup was created in.

Specifying a Destination File
You can tell the 824 Utility program where you want the
downloaded measurements to be stored. From the Download
window, press the Browse button, next to the Directory
entry.
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NOTE: The 824 Utility program will
download the files with the date the file
was taken as the file name as a default. It
will also download to the 824 Utility
Folder as a default. The option to specify
a file name and destination folder is an
optional selection, and is not necessary
for download.

A standard Windows file selection dialog box will appear.
Select the destination file you wish.

Changing the Download File Name
Enter a file name you wish to change the name of the downloaded file.
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Press the Save button to return to the download section of
the 824 Utility software.
Our new file name and
the path to the specified file now show on
the download screen.
These settings will
only apply for the currently selected measurement.
NOTE: This process will
have to be repeated for
each measurement to be
downloaded if you wish
to specify a file name and
destination folder.
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Adding Notes to a download file
Information can be entered into the note fields provided for
each measurement. The information will be tagged onto the
translated reports for each measurements.

Selecting Active Measurements or Data Files
There are two types of measurements that can be downloaded. The first measurement in the list is the Active measurement, and is reported as Active Measurement on the tab
of the download windows. The other measurements are
stored as Data Files (on the 824), and will be reported as
such on the tab of the download window.
Active Measurement
Data file
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Downloading the measurement
To download a measurement, highlight the measurement in
the Measurement list box and click the Download button.

The download status window will appear and report the status of the download.

The next file can now be selected, the destination folder
specified, the file name entered, and the data downloaded.
The resulting binary download file must be translated by the
824 utility software to be viewable. A downloaded file will
be stored with the file extension slmdl (Sound Level Meter
Down-load).
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Translating Measurement Data from a Downloaded File
Selecting “Translate View” from the View Menu or pressing
the Translate button on the tool bar will display the Translation View.

You use the Translate view to select a downloaded file with
the file extension .slmdl to translate and view the file on the
screen, or to print the file.
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The right portion of the Translate window functions as a
Windows file tree. Select the folder that contains the downloaded measurement files that you wish to translate.

Locate the folder that contains the downloaded file
you wish to translate. In this case we have found
the downloaded file in the default location, C:\Program Files\Larson Davis\824 Utility.

Each downloaded file will contain several records, depending on the type of setup used, and the data stored.

Downloaded measurement
file.

Data translated for the
Downloaded file.

9-24

System 824 Reference Manual

12/10/99

Selecting a Data set to view
After the downloaded file is located, double click on the data
you wish to view.

The data is displayed on the right side of the screen. If the
data record is too large to be effectively displayed in that
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area, a message will appear at the top of the displayed record
indicating that it is available for export only.
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Printing a Translated File
To print the translated data, select the file that you wish to
print from the translate window . Display the file as
described earlier. Select Print from the File menu.

12/10/99

Using the 824 Utility Software

9-27

The default Windows printer dialog box will be displayed.
The report will be printed in a text format seen below.
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Viewing a Translated File Within a Spreadsheet Program
To view the translated data with a spreadsheet program,
select the View Data in Spreadsheet menu item from the
File menu or the Launch Spreadsheet button on the tool bar.

When you select the View Data in Spreadsheet menu item,
the 824 utility program will attempt to launch the program
associated with the “.csv” file extension (comma separated
variables). If you have installed a spreadsheet program, your
Windows system will most likely have this file type linked
to a spreadsheet program.
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Once the data is in the spread sheet program it can be manipulated, stored, and graphed using the standard spreadsheet
functions.
You can also export and/or save the translated data to a file,
by selecting the Export Data menu item from the File menu.
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